MythTV:n pakkoruotsi TV:n ohjelmatiedoissa

Keskustelu osiossa 'HTPC eli Home Theater PC' , aloittajana Kassu62, 10.02.2013.

  1. Kassu62

    Kassu62 Käyttäjä

    Liittynyt:
    23.01.2008
    Viestejä:
    145
    Saadut tykkäykset:
    1
    Asensin MythTV:n uusiksi ja kävi kuten viime kerralla. Ohjelmatiedot ovat satunnaisesti ruotsiksi. Viimeksin osasin tehdä korjaukset oikeaan paikkaan, mutta nyt en löydä millään oikeaa asetustiedostoa.

    Asetus tehtänee Backend-koneelle kun Frontendia minulla ei ole lainkaan asenettuna. Katselen ohjemia TV:n DLNA:n tai Raspberry Pi:n OpenElecin kautta ja purkin sisätöä hallinnoin mythweb-käyttöliittymän kautta.
     
  2. tk_hyla

    tk_hyla Uusi jäsen

    Liittynyt:
    16.02.2012
    Viestejä:
    26
    Saadut tykkäykset:
    0
    Käytätkö AIR guidea vai XMLTV guidea?
    olen itse kanssa huomannut, että tuossa AIR guidessa on osa ruotsiksi. Omassa vanhassa Samsungin telkkarissa oli sama vika. en tiedä miks näin tulee.
     
  3. Kassu62

    Kassu62 Käyttäjä

    Liittynyt:
    23.01.2008
    Viestejä:
    145
    Saadut tykkäykset:
    1
    Käytän Air guidea eli se on sitä kanavanippujen mukana kulkevaa dataa.

    Sekakielisyys johtuu kuulema siitä, että joskus ruotsinkielinen ohjelmatieto tulee ensiksi (en tiedä onko tuohon jokin tekninen syy vai onko kyseessä kielien välinen tasa-arvoajattelu). Jos MythTV:lle ei sitä erikseen määrätä niin ohjelmatiedoissa näytetään se eka kieli.

    Eli jos vaihdan ohjelmaoppaan lähdettä niin ongelma ratkeaa?
     
  4. tk_hyla

    tk_hyla Uusi jäsen

    Liittynyt:
    16.02.2012
    Viestejä:
    26
    Saadut tykkäykset:
    0
    ok, eli Mythtv:lle ei pysty kertomaan, että käytetään vaihtoehtoisesti sitä tokaa ohjelmatietoa. Itse käytän tv_grab_fi xmltv dataa telvis tai mtv3 sivuston kautta. Tuolla saa 20 päivän ohjelmatiedot.
     
  5. Kassu62

    Kassu62 Käyttäjä

    Liittynyt:
    23.01.2008
    Viestejä:
    145
    Saadut tykkäykset:
    1
    Kyllä pystyisi, jos vain löytäisin oikean paikan. Kun säätömahdollisuuksia on aivan joka lähtöön niin sen oikean kohdan löytäminen on joskus kovin vaikeaa...
     
  6. tk_hyla

    tk_hyla Uusi jäsen

    Liittynyt:
    16.02.2012
    Viestejä:
    26
    Saadut tykkäykset:
    0
    Jos löydät tuon asetuksen jostain niin kerro ihmeessä. Tuota kanssa joskus ihmetellyt kun vielä käytin AIR guidea.
     
  7. morge

    morge Käyttäjä

    Liittynyt:
    23.07.2001
    Viestejä:
    227
    Saadut tykkäykset:
    0
    Tuskailin taannoin saman ongelman kanssa ja homma lähti muistaakseni pelittämään, kun lisäsi maakoodin backendiä pyörittävälle koneelle. Eli mysql auki ja settings-tauluun "Country"-koodi kuntoon myös backendin osalta. Oikeat arvot voi vakoilla vaikka frontendiä pyörittävän koneen riviltä, mutta ovat muotoa value=Country, data=FI, hostname=mikäikinäbackendinhostnameonkaan
     
  8. Kassu62

    Kassu62 Käyttäjä

    Liittynyt:
    23.01.2008
    Viestejä:
    145
    Saadut tykkäykset:
    1
    Kieliongelma korjautui tämän ohjeen perusteella
    http://www.mythtv.org/pipermail/mythtv-commits/2009-August/055053.html.

    'ISO639Language%'-kentissä hostname oli oletuksena 'LocalHost'. Tuo ei toimi silloin kun FrontEndia ajetaan eri koneelta kuin BackEnd. Itse hoidan ajastukset ja nauhoitusten hallinnan iPadin selaimella mythweb-käyttöliittymän kautta. Varsinaista FrontEndia en ole asentanut laisinkaan. Kun 'LocalHost'-teksti korvataan BackEnd-serverin hostnamella niin homma lähtee pelittämään. Korjauksen jälkeen ohjelmatietojen kieli vaihtuu pikku hiljaa halutuksi. Prosessi vie runsaan tunnin ja jokaisen muutetun ohjelmatiedon perään ilmestyy lisäteksti '(Tee uudelleen)'.