Kodin automaatioratkaisut

Keskustelu osiossa 'Kodin suunnittelunurkka' , aloittajana säätäjä, 21.01.2010.

  1. anon4340

    anon4340 Käyttäjä

    Liittynyt:
    17.04.2002
    Viestejä:
    287
    Saadut tykkäykset:
    0
    Tuo Alliedin kotelohan on ihan oikeaa rautaa, joka on aika eri verrattuna muovikoteloihin, jotka ovat lähinnä eristeitä, kun mietitään jäähdytystä.

    Olen edelleen jatkanut kotiautomaatio-ohjelmien läpikäyntiä, ja nyt jo olen alkanut miettimään että pitääkö tehdä itse ;) Joskohan Natikka toisi Raspberry 2:n Windows 10- sopivuuden myötä tuen Labview:lle, niin alkaisi insinöörikin osaamaan koodata :naminami: No tätä odotellessa voi tulla pitkä aika.

    Yritin eilen illalla muutaman vuoden taon jälkeen NetHomea, mutta millä siihen saisi:
    - Inputin (Sisääntulo jolla ohjataan jotain. Esim. laitetaan valo päälle.), joka on pelkästään virtuaalinen, jolla on rest- rajapinta? Eli mikä tahansa laite joka osaa tehdä http kyselyn voisi ohjata tätä.
    -Vastaavasti output, joka olisi pelkästää virtuaalinen. Kun tämä aktivoituu niin ohjelma, joko ajaisi jonkun scriptin, joka voisi taasen tehdä http kyselyn, tai tekisi suoraan http kutsun?

    Käsittääkseni tämä pitäisi onnistua, mutta en löytänyt ohjelmasta oikeita palikoita. Tuntui että aina olisi pitänyt sitoa inputit ja outputit johon tiettyyn esim. "laitteeseen".

    NetHomen dokumentointi on muuten parantunut viimekerrasta huomattavasti :naminami:
     
  2. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Ookkos anon kokeillu nethomen foorumia sieltä sais tekijältä varauksen.
     
  3. bj40

    bj40 Käyttäjä

    Liittynyt:
    06.10.2008
    Viestejä:
    111
    Saadut tykkäykset:
    2
    Jotain outoa taas menossa omassa nethome asennuksessa. Eilen ja tänään teki sellaista että katkaisimet eivät ohjanneet valoja mutta netti liittymästä ohjasi. Buutilla taas korjaantui. Pitänee päivittää uudempaan nightlyyn..
    Tai sitten viritettävä buutti kerran päivää.
     
  4. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Onhan sulla kunnon virtalähde tolle raspille?. jos siis rpi ssä ajat sitä, itellä ei kyl mitään ongelmaa koskaan jos ei oo ite tyriny. esim lähettää liian nopeasti liian monta tcp packetia nethomeen :D.
    Oliko nethomen logissa mitään ihmeellistä? esim event quee full tai jotain erroria ,
     
  5. bj40

    bj40 Käyttäjä

    Liittynyt:
    06.10.2008
    Viestejä:
    111
    Saadut tykkäykset:
    2
    juu 2A virtalähde on ja raspikin on mallia b+ eli se välimallin versio.
    en nyt tajunnu taas kokeilla kaikkia mutta tuo temppuileva katkasija on semmonen missä on se koodi kiekko. sekä myös kaukosäädin joka ohjaa pistorasiaa joka ei ole koodillinen. eli voisi olettaa koskevan kaikkia..
    kokeilen ens kerralla kaikki läpi ja otan logit talteen ne taitaa mennä bittiavaruuteen ettei kortille kirjoitella turhan usein.
     
  6. Don MC

    Don MC Aktiivinen käyttäjä

    Liittynyt:
    19.05.2005
    Viestejä:
    1 157
    Saadut tykkäykset:
    11
    Totta tosiaan. Itellä oli suuria ongelmia Raspin kanssa aluksi. Kokeilin montaa eri virtalähdettä, kunnes lopulta päädyin Nokia-merkkiseen 1,3A puhelinlaturiin. Oman kokemukseni perusteella Raspi ei tykkää halvoista (Biltema ym.) virtalähteistä. Eikä myöskään halvoista SD-korteista.
     
  7. bj40

    bj40 Käyttäjä

    Liittynyt:
    06.10.2008
    Viestejä:
    111
    Saadut tykkäykset:
    2
    joo siis tuo on pyörinyt tuolla useamman kuukauden (ehkä marraskuusta) ongelmitta, välillä taisi hukkua koko purkki ja buutilla taas korjaantui. eli ei se virtalähteestä ole kiinni.
    ja matrix taas koodasi koodia, eli hämärä muistikuva että taisi temppuilla edellisen asennuksen jälkeen kanssa tuolla tavalla ja taisin päivittää sen silloin tuoreimpaan versioon.

    olen kyllä tässä viime viikolla muuttanut nfs sharen polkun NASsin asennuksen myötä johon lämpötila anturin tallennukset menee enkä tietenkään muistanut muuttaa sitä polkua, korjasin nyt oikeaksi. täytyy seurailla ja tehdä vara katkaisija tuota eniten käytössä olevaa varten.
     
  8. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Juuh , saattaisi tietysti olla tuo nassin polku jos se jotenkin jää sitä etsiskeleen , tosin jos jako toimii niin tuskin sitten se on syynä. omassa systeemissä alkuun ihmettelin miksi ei valot katkasijasta toimi mutta nettiliittymästä toimi , vika oli niin tyhmä että imuri joka oli nojalla seinää vasten painoi yhtä katkaisijaa ja sai kaistan tukkoon, ilmeisesti lähetin oli voimaampi ja toimitti moduuleille signaalin minkä ne vielä vastaanotti , mutta vastaan otin ei kuullut kuin sitä yhtä nappia. kannattaa seuraavassa vika tilanteessa katsoa josko nethome kertoo jotain ongelmasta , sinne ilmestyy huutomerkki oikeeseen yläkulmaan jos logissa virheitä on. Itse perjantaina kaadoin juuri raspin , kun ruuvasin 9 onewire lämpömittarin lähetysajan liian kireelle ei tykännyt 9 udp paketista 2 sekunnissa vaan veti quuueee full ilmoitusta.Itse muuten hylkäsin ne koodipyörälliset kaukot ja rasiat alkoi olemaan niin vanhoja että sen kanavapyörän jalat oli paskaset ja alkoi pätkimään sitä signaalia , kauko esim hyppelehti itse kanavalta toiselle ja silloin tietenkään ei koodit tule perille jos kanavat vaihtuilee itsekseen , tuo nethomen telnetillä komentoporttiin yhteys ja sieltä tutkimaan signaaleita on myös vikatilassa iso apu. sieltä sen itsehuomasin että a ,1 kanava oli välillä a,3 b ,2 ,b1 jne vaikka rulla oli asennossa a ,1
     
  9. bj40

    bj40 Käyttäjä

    Liittynyt:
    06.10.2008
    Viestejä:
    111
    Saadut tykkäykset:
    2
    ei se siitä nassi yhteydestä ole. teki sen taas. ei toimi kumpikaan tuota nethomea reittinä käyttävä kytkintä, toinen on koodipyörällinen ja toinen ei.
    logista ei löytynyt mitään, enkä löytänyt tähän hätään sitä komentoa millä se kuuntelee telnetisssä.. piti saada valot pois ni buuttasin taas koko höskän...
     
  10. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Ohhoh hoh onpas mysteeri. nethomeen telnettiin pitiää komentaa subscribe
    niin se näyttää ne lähtevät ja tulevat eventit.
    vaatii varmaan enskis enter sitten subscribe ja enter , niin kauan että nethome vastaa ok
    aika mysteeri kyllä on jos nethomessa ei ole logeissa erroreita ja buutin jälkeen taas toimii ok.
     
  11. bj40

    bj40 Käyttäjä

    Liittynyt:
    06.10.2008
    Viestejä:
    111
    Saadut tykkäykset:
    2
    ainii subscribehan se taikasana oli..
    pitää vähän perehtyä kun saa muut projektit alta pois (on NASsia ja keittiön lattiaa :) )
    tuosta raspistahan olen kaikki korttia kuluttavat toiminnot laittanut pois päältä
    http://www.ideaheap.com/2013/07/stopping-sd-card-corruption-on-a-raspberry-pi/
    mietin jo kokonaan readonlyksi laittamista mutta en ole vielä saanut aikaiseksi varsinkin kun tuo alkoi temppuilemaan..
     
  12. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Jos tempuilu alkoi tuon ideahep linkin toimien jälkeen niin kokeile alk ui peräsillä asetuksilla. Saattaa olla että noista kortin säästö kikoissa menee jotain pieleen.
     
  13. ptp

    ptp Käyttäjä

    Liittynyt:
    03.08.2001
    Viestejä:
    81
    Saadut tykkäykset:
    0
    Kerkisin näitä vähän testailemaan.
    Tein "kitchenlamp" osoitteella 2000. Guista "kitchenlamp" tilaa muutettaessa tulee telnettiin komento "event,NexaL_Message,Direction,Out,NexaL.Address,2000,NexaL.Button,1,NexaL.Command,0,Value," ja jos saman syöttää telnettiin takaisin niin vastauksena tulee virheviesti "error,10,No attribute value for Event attribute: Value"

    Samoin mulla on kytkin osoitteessa 2001 jonka OnCommand tekee "kitchenlamp" toggle. Guin kautta kytkintä painaessa lamppu vaihtaa tilaa ok.
    Sitten syötän telnettiin komennon "event,NexaL_Message,Direction,Out,NexaL.Address,2001,NexaL.Button,1,NexaL.Command,1,Value," niin tulee sama virheviesti.

    Ainut tapa jolla saan telnetin kautta lampun tilan muutettua on komento "call,kitchenlamp,toggle (tai on/off)"

    Eli jotain en noissa event-viesteissä nyt käsitä?

    Näyttäisi olevan täs vbulletinissa joku omituisuus kun noihin osoitteisiin tulee väli vaikka muokkaustilassa sitä ei olekaan...
     
  14. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Kummaa value perästä pois , pitäs rox sen jälkeen.
    Jos ei niin testaan illemalla asiaa.
     
  15. ptp

    ptp Käyttäjä

    Liittynyt:
    03.08.2001
    Viestejä:
    81
    Saadut tykkäykset:
    0
    Jep, nyt ei vastauksena tule erroria vaan ok ja sama event-rivi value-lopulla. Eli kytkimenkin osoite antaa kytkimen osoitteen.
    Mutta vaikka osoitteena on lamppu tai kytkin, niin guissa ei kuitenkaan lampun tila muutu.
     
  16. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    tama rivi sammuttaa tai sytyttää vessan valoa ,
    event,NexaL_Message,Direction,Out,NexaL.Address,9540794,NexaL.Button,10,NexaL.Command,0
    riippuen command parametristä
    1 = päälle = pois päältä
    ja huom sun pitää lähettää eventtinä se control itemin osoite ei lampun.
    eli sulla on ne lamput siellä nethomessa tehty , niitä sun pitää vaan lukea sinne logiigga yksikölle , se control item eli remap ohjaa taas sisään tulevaa liikettä.
    lähettele eventtejä nille control iitem (remap) koodeilla ja lue lampun eventtejä logiigalle silloin se pitas toimia ok
    ääh en oikeen osaa selittää mut yksinkertaisen sekavasti selitettynä. Lähetä kytkimen eventtejä nethomeen , ja lue lampun eventtejä logiigalle. silloon se menee oikeen.
    Tällä systeemillä saat nethomessa mapattua jonkun kytkimen johonkin lampppun eikä tarvitsisi sitä logiiggaa sen pahemmin koodailla. jaa -a en osaa ees kyllä suomee enää mikäköhän toi mapattu on suomeks :D toivottavasti ymmärrät mitä haen takaa.
    jaa , eipä toi edes tarvii enää sinne viimosta pilkkua sekin on varmaan jossain versiossa muuttunut , ennen ainakin sai vastaukseksi ok jos pilkku rivin perästä puuttui muttei tapahtunut mitään.
    Kai telnetissä komennat sitten ensiks subscribe jotta se ottaa ne eventit vastaan en oo varma toimiiko ilman subscibeä.
    eli itse tein niin että avasin telnetin nethome command porttiin
    painoin kerran enter jotta nethome vastaa ok.
    sitten subscribe
    ja enter
    tulee vastaukseks taas ok
    sitten näen esim laukasin vessan liiketutkan käsin napista niin saan tuon event rivin , sen copy pastesin takas ja valo sammuu ja syttyy vessassa kun vaihtaa sen command= numeroa.
     
    Viimeksi muokattu: 03.03.2015
  17. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Itse meinaan simuloin tuota lähetystä onewire raspista nethomeen tällä perl scriptillä:
    Koodi:
    #!/usr/bin/perl
    use strict;
    use warnings;
    use IO::Socket;
    
    my  $device = "10.BB59D9020800";
    my $sensordata = `cat /onewire/devices/$device/temperature 2>&1`;
    
         my  $ret = $sensordata*1000;
    $ret =  sprintf("%.0f", $ret);
    
    #sent tcp packet nethome
    my $sock = IO::Socket::INET->new(
        Proto    => 'udp',
        PeerPort => 8005,
        PeerAddr => '192.168.1.250',
    ) or die "Could not create socket: $!\n";
    
    print $sock "event,UPM_Message,Direction,In,UPM.DeviceCode,7,UPM.HouseCode,1,UPM.Primary,$ret,UPM.Secondary,122,UPM.SequenceNumber,0\n"  or die "Sent failed : $!";
    
    my $sock1 = IO::Socket::INET->new(
        Proto    => 'udp',
        PeerPort => 8005,
        PeerAddr => '127.0.0.1',
    ) or die "Could not create socket: $!\n";
    
    print $sock1 "event,UPM_Message,Direction,In,UPM.DeviceCode,7,UPM.HouseCode,1,UPM.Primary,$ret,UPM.Secondary,122,UPM.SequenceNumber,0\n"  or die "Sent failed : $!";
    
    tuossa lähetän onewire datan nethomelle event, upm lämopömittarina , niin pakko sun on saada toimimaan tuommoisen katkasimen lähetys nethomeen.
    tuossa muuten tarkkasilmäinen huomaa että lähetän tuon datan 2 eri koneella olevaan nethomeen , oon tekemässä automaattista backup piitä joka hyppää hommiin jos ensimmäinen primary kone kuolee tai tarvitsee sulkea se vaikka päivityksen takia , en oo vielä automaattista siirtoa kerenny väkertelee mutta siellä toimii jo täysi klooni ensimmäisestä , kaikki lamppujenkin tilat on valmiina , toteutettu niin että vara nethomessa on tellstick kuuntelulla eikä lähätä mitään komentoja kunnes kytketään lähetys protokollat päälle.
     
    Viimeksi muokattu: 03.03.2015
  18. ptp

    ptp Käyttäjä

    Liittynyt:
    03.08.2001
    Viestejä:
    81
    Saadut tykkäykset:
    0
    Lämpötilat toimivat esimerkkisi mukaan:
    "event,UPM_Message,Direction,In,UPM.DeviceCode,1,UPM.HouseCode,1,UPM.Primary,10,UPM.Secondary,122,UPM.SequenceNumber,0"
    Ja ko Device ja HouseCodelle tehty lämpömittari alkaa näyttämään lukemia. Ja kun "10" muuttaa niin lukemat vaihtuvat. Eli liikenne kulkee telnetistä nethomeen.


    Kiitos, kyllä tuosta ymmärrän miten homman pitäisi lähteä toimimaan...

    Eli tein saman lampun ja kytkimen kuin sulla on sivullasi:
    katso liitettä kitchenlamp.jpg
    katso liitettä kitchenswitch.jpg
    Vieläpä samoilla osoitteilla yms. Telnetissä komennan subscribe ja tämän jälkeen "event,MinuteEvent"-viestit tulevat näyttöön sekä enterin jälkeen tulee ok.
    Tuon antamasi rivin laitan telnettiin niin se vastaa ok ja lisäksi sama rivi ja ",Value," perässä, mutta mitään ei tapahdu guissa tuolle kitchenlampulle. Oli command sitten 1 tai 0, lamppu päällä tai sammunut.

    Tuossa esimerkissäsi kiinnittää huomion se, että sekä lampulla, että kytkimellä on sama osoite, eli sulla on siis siinä myös suora ohjaus ilman nethomea?
    Aikaisemmin mun lampussa oli osoite 2000 ja kytkimessä 2001, mutta tällähän oli sama vaikutus - eli ei toiminut.

    Vähän kaukaa haettua, mutta voisiko olla jotain tekemistä sillä, että mullahan ei ole Tellstickkiä, kiertäisikö nuo viestit sulla jotenkin sen kautta takaisin nethomeen?
    Saatko kokeiltua raspilla missä ei ole tikkua paikallaan?
     
  19. Nasty76

    Nasty76 Käyttäjä

    Liittynyt:
    17.10.2013
    Viestejä:
    194
    Saadut tykkäykset:
    0
    Ups wessan walo on suoralla ohjauksella 2min ja testaan.
    tama rivi tulee kun painan nexan langatonta painiketta.
    event,NexaL_Message,Direction,In,NexaL.Address,9795278,NexaL.Button,12,NexaL.Command,1,Value,


    copy pasteen tämän rivin takaisin,
    event,NexaL_Message,Direction,In,NexaL.Address,9795278,NexaL.Button,12,NexaL.Command,1
    nyt mun tolpat toglettaa koska remapissa on määritetty nappi 1 olohuone tolpat toggeksi
    0 käsky toglettaa mun katto valoa koska remap item off toiminto on mapattu katto toggeksi
    kuva tässä mun remap itemissä,
    https://www.dropbox.com/s/qltcv2mqudvwjwi/123jaa.png?dl=0

    eli kun tutkitaan tuota mun remap itemiä
    lähetät event, address 979nönnönnöö , button 12 ja 1 koodin joka on on ja 0 on off , niin
    button12, 1 tekee oncommand mukaisen toiminnon eli olohuonetolpat toggle , vastaavasti button 1 , 0 tekee offcomandin joka on siis olohuone toggle
    tällä systeemillä voit mappauksen hoitaa nethomessa kunhan oot arponut vaikka noita nexan address button itemeitä sinne logiigalle.
    vastaavasti lamput event messut luet takasin logiigaakalle että lamppu 222xxxxx , button 10 , on logiigassa pin 1 high etc.
    mun sivuila? tipahin kärryiltä :D täällä on mun demo nethome http://lemstrom.eu:8020/home?page=plan ei siellä taida kitchen lightiä olla :D.
    itekkin sekoilin tuoss enen kuin testasin enhän muistaanut jos remap itemin komentoja lähettetään niin jos ne on mapattu toggleksi niin address xxxxx,button xxx , komento 0 on aina sen lampoon toggle jos niin on mapattu , mutta joo 0 on sen kanavan off comento ja 1 on on komento tuolla remap itemis
    eikä mulla tossa päänethome koneessa oo tellstickiä , vaan omatekemät lähetin vastaan otin mutta ei se voi kiertää niitten kautta kun se tavallaan survotaan virtuaali sisääntulevana eventtinä eli ihan kuin joku olisi painanut nappia ,
    Btw tuli mieleen että jos et ole nethomewsa plan sivulla ,sivu ei autopäivity joten avaa lampu uusiks tai refresh selain ikkuna.
     
    Viimeksi muokattu: 04.03.2015
  20. ptp

    ptp Käyttäjä

    Liittynyt:
    03.08.2001
    Viestejä:
    81
    Saadut tykkäykset:
    0
    Nyt löytyi syy toimimattomuuteen.
    Näissä riveissä on pieni ero:

    Eli tuo suunta, sisään ja ulos. In = komennot nethomen suuntaan.
    Nyt siis näyttäisi toimivan mun tapauksessa niinkuin pitääkin, kiitoksia!
    Täytyy tutkia seuraavaa siirtoa tässä projektissa.