ASIO: Audio Stream In/Out ja sen käyttöönotto (foobar2000 & winamp)

Keskustelu osiossa 'HTPC eli Home Theater PC' , aloittajana Chauron, 19.03.2005.

  1. jomb

    jomb Member

    Liittynyt:
    01.03.2009
    Viestejä:
    33
    Saadut tykkäykset:
    0
    ajaako toi wasapi täysin saman asian kuin asio? en saanut asio:a toimimaan vistassa. soitin on foobar2000 ja terratec aureon dual usb optisella kiinni vahvistimessa.
     
  2. warre

    warre Active Member Tukijoukot

    Liittynyt:
    14.02.2000
    Viestejä:
    2 286
    Saadut tykkäykset:
    12
    exclusive-moodissa toimiva wasapi (kuten tuo foobarin plugin) ajaa saman asian kuin asio. foobarissa kannattaa tuon wasapin kanssa kokeilla eri ulostulo bittisyysasetuksia, itselläni emolevyn alc888 -piirin kanssa piti käyttää 24bit-asetusta.
     
  3. jomb

    jomb Member

    Liittynyt:
    01.03.2009
    Viestejä:
    33
    Saadut tykkäykset:
    0
    toi terratec ei tue kuin 16bit eli onko sitä hyötyä muuttaa?
     
    Viimeksi muokattu: 30.12.2009
  4. warre

    warre Active Member Tukijoukot

    Liittynyt:
    14.02.2000
    Viestejä:
    2 286
    Saadut tykkäykset:
    12
    ei ole. isommat ei taida edes silloin toimia.(ainakaan oikein)
     
  5. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Kohta lähtee kone ikkunasta pihalle ja nopeesti jos ei ala toimimaan...

    ELi eli, en ole saanut ASIOa, KERNELiä tai WASABIa toimimaan kertaakaan, missä vika? Kone on ihan perus ACER M5300 WIN 7 64bit gigantista ostettu. Äänet tulee näytönohjaimen kautta HDMI kaapelia pitkin maralle ja siitä tietenkin kaiuttimiin. Threadin ekalla sivulla olevat linkit ei toimi joten olen hakenut ajurit winamp:in sivuilta, ajurit löytyy ja on asennettu winamp:in plugins kansioon, settings -->preferences -->outputs -->asio/kernel/wasapi siis joku noista valittuna ja mikään ei toimi sen jälkeen winamp:ssa. Ei edes kappaleet lähe liikkeelle:OI:OI.

    Auttakkee Auttakkee, en ossaa:hitme:
     
  6. MkH^

    MkH^ New Member

    Liittynyt:
    29.03.2004
    Viestejä:
    15
    Saadut tykkäykset:
    0
    Olen yrittänyt nyt hetken aikaa saada tuota ASIO:a (ASIO4ALL 2.10) toimimaan Foobarin (1.1.4) kanssa. Äänilähteenä on Nuforce uDAC2.

    Olen asentanut Foobar pluginin, asettanut output-kohdasta ASIO:n käytettäväksi äänilähteeksi ja vastaavasti ASIO:n valikosta valinnut DAC:in käyttöön.

    Ongelma ilmeneekin siinä vaiheessa, kun yritän laittaa jonkin kappaleen soimaan: mitään ei tapahdu. Edes Foobarin "seek bar" ei liikahda. ASIO-ilmoitus pomppaa kyllä trayhin näkyviin, mutta ikoni muuttuu välittömästi punaiseksi (error?).

    Mitähän tässä voi vielä kokeilla?

    Kone: Abit AB9 Pro, C2D E6600, 4Gt 667MHz, 8800GTS, Nuforce uDAC2, W7 64bit.
     
  7. Maxi

    Maxi HT-hörhö mallia 101 Tukijoukot

    Liittynyt:
    15.04.2002
    Viestejä:
    2 629
    Saadut tykkäykset:
    10

    Otachanin 071 (x64) plugin WinAmp 2/5:lle. Samalta sivustolta löytyy myös 32-bittiset versiot. Tuon asentamisen jälkeen näkyykö pluginin tiedoissa, että mikä "ASIO-laitetta" tuo käyttää ? Edit: tuli mieleen, että kai myös WinAmp on sitten myös 64 bittinen ? Luulisin, että soittimen ja pluginin pitäisi olla samaa bittisyyttä....
     
    Viimeksi muokattu: 28.02.2011
  8. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Nyt sain ekaa kertaa näkyy tuolla alaalla ton ASIO4ALL:in "pause" merkin ja pääsin winamp:in preference:stä laittaa sen asion päällä ja pääsin sen valikkoon, mut silti ei musiikki kuulu, kuuluu naps ja loppuu. Jos vielä viittit vähän opastaa ni ei tartte heittää ikkunasta konetta pihalle... tai sit et auta ja tuut ikkunan alle oottaa et millon se kone tulee sieltä :D:D
     
  9. Maxi

    Maxi HT-hörhö mallia 101 Tukijoukot

    Liittynyt:
    15.04.2002
    Viestejä:
    2 629
    Saadut tykkäykset:
    10
    Oletko käynyt kokeilemassa tätä
    Kannattaa myös varmistaa, että koneessa on tuoreimmat äänikortin ajurit.
     
  10. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Iso kiitos ja kumarrus, sain sen toimimaan. Mutta en tiedä toimiiko se aivan oikein, kun säädän joko winamp:sta tai win:sta volumea ei ääni kovene, pitääkö sen mennä näin vai onko sillä mitään merkitystä?
     
  11. Maxi

    Maxi HT-hörhö mallia 101 Tukijoukot

    Liittynyt:
    15.04.2002
    Viestejä:
    2 629
    Saadut tykkäykset:
    10
    Pitää mennä juuri näin, äänenvoimakkuuden säätö tapahtuu vahvistimessa/DACissa. Näiden tekniikoiden idea on ohittaa käyttiksen/piirin/kortin omat bugiset mikserit/EQ:t yms. äänenlaatua huonontavat viritelmät ja viedä ääni soitto-ohjelmasta semmoisenaan eteenpäin äänikortin/piirin ulostoihin.
     
  12. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Eli se toimii sittenkin :). Mutta, mutta, tuli semmonen tenkkapoo, et vahvistimessa lukee multich 7.1 ja subi ei puhalla eikä pukahda... Tämä nyt ei varsinaisesti haittaa ku käytän direct:iä, mutta jos välillä haluaa luukuttaa naapureilta vahat korvista ni se ei enää onnistu:D:OI. Enkä pysty nyt testaamaan et kuuluko kaikista kaiuttimista, ku 1 pari cm1 on lainassa.
    Milläs tota nyt pystyisin testaa et toimiiko oikein?
     
  13. Maxi

    Maxi HT-hörhö mallia 101 Tukijoukot

    Liittynyt:
    15.04.2002
    Viestejä:
    2 629
    Saadut tykkäykset:
    10
    Hanki jostakin DTS-FLAC -tiedosto ja soita se toisto-ohjelmassa. Jos waffi raportoi "DTS" niin silloin ketju vahvistimelle saakka on kunnossa. Subin säätöihin tällä touhulla ei ole vaikutusta. En tiedä tosin, että mitä virityksiä sulla oli ennen jos esim. LFE generoitiin jollakin perverssillä tavalla lennossa piirin/kortin toimesta.
     
  14. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Viittiskö joku laittaa linkkiä tai jotain paikkaa kertoo mistä tommosia löytäis. En oo ite löytäny mitään tommosta...
     
  15. kurg

    kurg Active Member Tukijoukot

    Liittynyt:
    20.07.2002
    Viestejä:
    1 082
    Saadut tykkäykset:
    1
    Googlaa "DTS WAV" ja pakkaa FLAC:ksi. En kyllä tiedä miksi pitäisi olla juuri FLAC. Luultavasti WAV kelpaa yhtä hyvin. Myös DD-WAV/FLAC kelvannee.

    Laitetaan muutama siltä varalta, jos ei google ole tuttu :D
    http://www.kellyindustries.com/sounds.html
    http://www.diatonis.com/downloads_dts_ac3.html
     
    Viimeksi muokattu: 04.03.2011
  16. Maxi

    Maxi HT-hörhö mallia 101 Tukijoukot

    Liittynyt:
    15.04.2002
    Viestejä:
    2 629
    Saadut tykkäykset:
    10
    Ainakin tuo "Diatonis - The Secret Universe" DTS-WAV (zip-purun jälkeen) meni aivan OK lävitse (waffi raportoi DTS) eli ei tietenkään tartte olla FLAC-pakattu. FLAC-tiedostoina noihin vaan useimmin törmää ja FLAC-tiedostoja ei tarvitse erikseen purkaa toistoa varten :)
     
  17. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Kiitoksia molemmille avusta, Etenkin Maxi:lle :thumbsup: . En tosin juuri nyt pääse testailemaan tuota, mutta su illalla taas jahka kotia pääsen. Raportoin sit kuinka käy....
     
  18. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    Suhinaa, suhinaa...... Missä vika?
     
  19. Maxi

    Maxi HT-hörhö mallia 101 Tukijoukot

    Liittynyt:
    15.04.2002
    Viestejä:
    2 629
    Saadut tykkäykset:
    10
    Niin jos siis kokeilit tuolla 44.1 kHz DTS-kamalla niin tuo tarkoittanee sitä, että jokin muuttaa ääntä tuossa ketjussa eikä tavara mene semmoisenaan soitto-ohjelmasta eteenpäin. Tämä diagnoosi siis siinä tapauksessa jos ei-DTS -musiikki kuitenkin kuuluu.

    Ilmeisesti tuon ATIn näytönohjaimen mukana ei tullut mitään erillisiä ASIO-ajureita ? Ei kai tuolla ASIO4ALL-puolella tai WinAmpin ASIO-plugissa ole mitään rastia 48 kHz resamplaukseen liittyen ? Tätä resamplaus-asetusta saa käyttää vain jos kortti/piiri ei natiivina tue 44.1 kHz kaman ulostuloa ilman resamplausta.
     
    Viimeksi muokattu: 07.03.2011
  20. Scar"Face"

    Scar"Face" New Member

    Liittynyt:
    11.05.2009
    Viestejä:
    157
    Saadut tykkäykset:
    0
    ^ En löytänyt ainakaan tohon näyttikseen mitään ASIO:eek:n liittyvää...
    Kokeilin juurikin tuota Diatonis- DTS- Secret Universe. Ja Resamplay:stä kone varmaan tekee, kun se tommoseks PINK-noise:n tapaseks äänen muuttaa.

    Kuva vielä asetuksista
     

    Liitetyt tiedostot: